福德彩票注册平台

设为福德彩票注册平台 加入收藏

TOP

Cisco VLAN 配置命令详解之七
2009-03-01 08:04:27 来源: 作者: 【 】 浏览:26588

1.2  基于端口的VLAN配置命令

1.2.1  port

【命令】

port interface-list

undo port interface-list

【视图】

VLAN视图

【参数】

interface-list:需要添加到某个VLAN中或从某个VLAN中删除的以太网端口列表,表示方式为interface-list = { interface-type interface-number [ to interface-type interface-number ] }&<1-10>。其中interface-type interface-number福德彩票注册平台为端口类型和端口号。&<1-10>表示前面的参数最多可以输入10次。

【描述】

port命令用来向VLAN中添加一个或一组Access端口。undo port命令用来从VLAN中删除一个或一组端口。

需要注意的是:

             该命令只对Access端口有效。

             设备上的所有端口的缺省链路类型都是Access类型,但用户可以自行切换端口类型,具体配置请参见命令port link-type

相关配置可参考命令display vlan

【举例】

福德彩票注册平台# 向VLAN 2中加入从GigabitEthernet 1/0/1到GigabitEthernet 1/0/3的以太网端口。

<Sysname> system-view

福德彩票注册平台[Sysname] vlan 2

福德彩票注册平台[Sysname-vlan2] port GibabitEthernet 1/0/1 to GigabitEthernet 1/0/3

1.2.2  port access vlan

【命令】

port access vlan vlan-id

undo port access vlan

【视图】

以太网端口视图/端口组视图

【参数】

vlan-id福德彩票注册平台:指定的VLAN ID,取值范围为1~4094。

【描述】

port access vlan命令用来将当前Access端口加入到指定的VLAN中。undo port access vlan福德彩票注册平台命令用来把Access端口恢复到缺省VLAN中。

对Access端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN会变成VLAN 1。

在以太网端口视图下执行该命令,则该配置只在当前端口生效;在端口组视图下执行该命令,则该配置将在端口组中的所有端口生效。(端口组的相关配置请参见”端口相关配置”模块中的端口组部分)

此命令使用的条件是vlan-id所指定的VLAN必须存在。

【举例】

# 将GigabitEthernet 1/0/2端口加入到VLAN3中。

福德彩票注册平台<Sysname> system-view

福德彩票注册平台[Sysname] vlan 3

福德彩票注册平台[Sysname-vlan3] quit

[Sysname] interface GigabitEthernet 1/0/2

福德彩票注册平台[Sysname-GigabitEthernet 1/0/2] port access vlan 3

1.2.3  port hybrid pvid vlan

【命令】

port hybrid pvid vlan vlan-id

undo port hybrid pvid

【视图】

福德彩票注册平台以太网端口视图/端口组视图

【参数】

vlan-id:指定接口的缺省的VLAN ID,取值范围为1~4094。

【描述】

port hybrid pvid vlan命令用来设置Hybrid端口的缺省VLAN ID。undo port hybrid pvid命令用来恢复缺省情况。

缺省情况下,Hybrid端口的缺省VLAN为VLAN1。

对Hybrid端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN配置不会改变,即可以使用已经不存在的VLAN作为缺省VLAN。

福德彩票注册平台在以太网端口视图下执行该命令,则该配置只在当前端口生效;在端口组视图下执行该命令,则该配置将在端口组中的所有端口生效。(端口组的相关配置请参见”端口相关配置”模块中的端口组部分)

相关配置可参考命令port link-type

【举例】

# 将Hybrid端口GigabitEthernet1/0/4的缺省VLAN设为VLAN 100。

福德彩票注册平台<Sysname> system-view

福德彩票注册平台[Sysname] vlan 100

[Sysname-vlan100] quit

[Sysname] interface GigabitEthernet 1/0/4

[Sysname-GigabitEthernet1/0/4] port link-type hybrid

福德彩票注册平台[Sysname-GigabitEthernet1/0/4] port hybrid pvid vlan 100

1.2.4  port hybrid vlan

【命令】

port hybrid vlan vlan-id-list { tagged | untagged }

undo port hybrid vlan vlan-id-list

【视图】

福德彩票注册平台以太网端口视图/端口组视图

【参数】

vlan-id-list:VLAN列表,表示Hybrid端口要加入的VLAN的范围。表示方式为vlan-id-list = { vlan-id1 [ to vlan-id2 ] }&<1-10>, vlan-id1vlan-id2的取值范围均为1~4094,且vlan-id2不能小于vlan-id1。&<1-10>表示前面的参数最多可以重复输入10次。

tagged:指定VLAN的报文发送时携带Tag标签。

untagged福德彩票注册平台:指定VLAN的报文发送时不带Tag标签。

【描述】

port hybrid vlan命令用来允许指定的VLAN通过当前Hybrid端口。undo port hybrid vlan命令用来取消指定的VLAN通过当前Hybrid端口。

Hybrid端口可以允许多个VLAN通过。如果多次使用port hybrid vlan命令,那么Hybrid端口上允许通过的VLAN将是各次操作使用的vlan-id-list福德彩票注册平台参数所表示VLAN的合集。

福德彩票注册平台在以太网端口视图下执行该命令,则该配置只在当前端口生效;在端口组视图下执行该命令,则该配置将在端口组中的所有端口生效。(端口组的相关配置请参见”端口相关配置”模块中的端口组部分)

相关配置可参考命令port link-type

【举例】

# 配置Hybrid端口GigabitEthernet1/0/4允许VLAN2、VLAN4、VLAN50~VLAN100通过(指定的VLAN都已经存在),并且这些VLAN的报文发送时携带Tag标签。

福德彩票注册平台<Sysname> system-view

[Sysname] interface GigabitEthernet 1/0/4

福德彩票注册平台[Sysname-GigabitEthernet1/0/4] port link-type hybrid

[Sysname-GigabitEthernet1/0/4] port hybrid vlan 2 4 50 to 100 tagged

Please wait... Done.

福德彩票注册平台# 配置端口组2内的Hybrid端口允许VLAN2通过,并且这些VLAN的报文将不会带有标签。

<Sysname> system-view

[Sysname] vlan 2

福德彩票注册平台[Sysname-vlan2] quit

福德彩票注册平台[Sysname] port-group manual 2

[Sysname-port-group-manual-2] group-member GigabitEthernet 1/0/1 to GigabitEthernet 1/0/6

[Sysname-port-group-manual-2] port link-type hybrid

福德彩票注册平台[Sysname-port-group-manual-2] port hybrid vlan 2 untagged

 Configuring GigaibitEthernet1/0/1... Done.

 Configuring GigaibitEthernet1/0/2... Done.

 Configuring GigaibitEthernet1/0/3... Done.

 Configuring GigaibitEthernet1/0/4... Done.

 Configuring GigaibitEthernet1/0/5... Done.

 Configuring GigaibitEthernet1/0/6... Done.

1.2.5  port link-type

【命令】

port link-type { access | hybrid | trunk }

undo port link-type

【视图】

以太网端口视图/端口组视图

【参数】

access福德彩票注册平台:设置端口的链路类型为Access类型。

hybrid福德彩票注册平台:设置端口的链路类型为Hybrid类型。

trunk福德彩票注册平台:设置端口的链路类型为Trunk类型。

【描述】

port link-type命令用来设置端口的链路类型。undo port link-type命令用来恢复缺省情况。

缺省情况下,所有端口的链路类型均为Access类型。

在以太网端口视图下执行该命令,则该配置只对当前端口生效;在端口组视图下执行该命令,则该配置将对端口组中的所有端口生效。(端口组的相关配置请参见”端口相关配置”模块中的端口组部分)

说明:

Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为其他类型端口。例如:Trunk端口不能直接被设置为Hybrid端口,只能先设为Access端口,再设置为Hybrid端口。

 

【举例】

福德彩票注册平台# 将以太网端口GigabitEthernet1/0/1设置为Trunk类型端口。

<Sysname> system-view

福德彩票注册平台[Sysname] interface GigabitEthernet 1/0/1

福德彩票注册平台[Sysname-GigabitEthernet 1/0/1] port link-type trunk

1.2.6  port trunk permit vlan

【命令】

port trunk permit vlan { vlan-id-list | all }

undo port trunk permit vlan { vlan-id-list | all }

【视图】

福德彩票注册平台以太网端口视图/端口组视图

【参数】

vlan-id-list:VLAN列表,为Trunk端口加入的VLAN的范围,表示方式为vlan-id-list = { vlan-id1 [ to vlan-id2 ] }& <1-10>,vlan-id1vlan-id2的取值范围均为1~4094,且vlan-id2不能小于vlan-id1,&<1-10>表示前面的参数最多可以重复输入10次。

all:表示允许所有VLAN通过该Trunk端口。

【描述】

port trunk permit vlan命令用来允许指定的VLAN通过当前Trunk端口。undo port trunk permit vlan命令用来取消指定的VLAN通过当前Trunk端口。

Trunk端口可以允许多个VLAN通过。如果多次使用port trunk permit vlan命令,那么Trunk端口上允许通过的VLAN将是各次操作使用的vlan-id-list福德彩票注册平台参数所表示VLAN的合集。

在以太网端口视图下执行该命令,则该配置只在当前端口生效;在端口组视图下执行该命令,则该配置将在端口组中的所有端口生效。(端口组的相关配置请参见”端口相关配置”模块中的端口组部分)

相关配置可参考命令port link-type

【举例】

# 配置Trunk端口GigabitEthernet1/0/4允许VLAN2、VLAN4、VLAN50~VLAN100通过(指定的VLAN已经创建)。

福德彩票注册平台<Sysname> system-view

福德彩票注册平台[Sysname] interface GigabitEthernet1/0/4

福德彩票注册平台[Sysname-GigabitEthernet1/0/4] port link-type trunk

[Sysname-GigabitEthernet1/0/4] port trunk permit vlan 2 4 50 to 100

福德彩票注册平台Please wait........... Done.

1.2.7  port trunk pvid vlan

【命令】

port trunk pvid vlan vlan-id

undo port trunk pvid

【视图】

福德彩票注册平台以太网端口视图/端口组视图

【参数】

vlan-id福德彩票注册平台:指定接口的缺省VLAN ID,取值范围为1~4094。

【描述】

port trunk pvid vlan命令用来设置Trunk端口的缺省VLAN ID。undo port trunk pvid命令用来恢复缺省情况。

缺省情况下,Trunk端口的缺省VLAN为VLAN1。

对Trunk端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN配置不会改变,即使用已经不存在的VLAN作为缺省VLAN。

在以太网端口视图下执行该命令,则该配置只在当前端口生效;在端口组视图下执行该命令,则该配置将在端口组中的所有端口生效。(端口组的相关配置请参见”端口相关配置”模块中的端口组部分)

福德彩票注册平台需要注意的是,本端设备Trunk端口的缺省VLAN ID和相连的对端设备的Trunk端口的缺省VLAN ID必须一致,否则报文将不能正确传输。

相关配置可参考命令port link-type

【举例】

福德彩票注册平台# 将端口GigabitEthernet1/0/4的链路类型设置为Trunk,缺省VLAN设置为VLAN 100。

<Sysname> system-view

福德彩票注册平台[Sysname] interface GigabitEthernet1/0/4

福德彩票注册平台[Sysname-GigabitEthernet1/0/4] port link-type trunk

[Sysname-GigabitEthernet1/0/4] port trunk pvid vlan 100


 
 
上一篇没有了 下一篇Cisco VLAN 配置命令详解之四、五..

最新文章

图片主题

热门文章